4 thoughts on “Hijacking the main WordPress query and loop for fun and profit

    1. John P. Bloch Post author

      Yes, you’re quite right Jared. An artifact of my ignorance. Thanks for the note. 🙂

      Reply
    2. Madalin

      I know I come with 1y and 1m later, but for Jared, PHP 5.2.x EOL happened in “6 Jan 2011”. So we’re supposed to use a maintained release for “security” reasons, right?

      Reply
      1. John P. Bloch Post author

        5.2.4 is still the minimum supported version for WordPress core. The decision regarding supporting the 5.2 and 5.3 branches of PHP is one that each developer needs to make for themselves. My rule of thumb is that if I distribute my plugin on the main repository, I support the same versions as WordPress unless there’s a very good technical reason to do otherwise. Other code generally does not support unsupported versions of PHP.

        Reply

Leave a Reply

Your email address will not be published. Required fields are marked *